Bezpečnostní balíček Apple 2007-004

Bezpečnostní balíček Apple 2007-004

Bezpečnostní aktualizace 2007-004 je doporučená všem uživatelům a má vylepšovat následující komponenty:

  • AFP klient
  • AirPort
  • CarbonCore
  • diskdev_cmds
  • fetchmail
  • ftpd
  • gnutar
  • Help Viewer
  • HID Family
  • Installer
  • Kerberos
  • Libinfo
  • Login Window
  • network_cmds
  • SMB
  • Sytem Configuration
  • URLMount
  • Video Conference
  • WebDAV

A teď podrobněji:

  • AFP Client
    • CVE-ID: CVE-2007-0729
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9, klientské i serverové verze
    • Důsledky: lokální uživatel může získat systémová práva.
    • Příčina: Za určitých okolností AFP klient může spustit příkaz bez správně nastaveného prostředí, to dovolí lokálnímu uživateli přistupovat k souborům neb spouštět příkazy se systémovými právy. Aktulizace opravuje problém vyčištěním prostředí před spouštěním příkazů.
  • AirPort
    • CVE-ID: CVE-2007-0725
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9, klientské i serverové verze
    • Důsledky: lokální uživatel může spouště kód se zvýšenými právy
    • Příčina: AirPortDriver modul měl v sobě chybu způsobující přetečení bufferu. Odesláním špatně sestaveného příkazu může uživatel spustit toto přetečení, což může vést ke spuštění kódu se systémovými právy. Problém je pouze u originálních AirPort karet počítačpů eMac, iBook, iMac, PowerBook G3, PowerBook G4 a Power Mac G4 systémů. Problém nezahrnuje systémy s AirPort Extreme kartou. Aktualizace opravuje problém provedením kontrol řídících příkazů.
  • CarbonCore
    • CVE-ID: CVE-2007-0732
    • Dostupný pro: Mac OS X 10.4.9, klientské i serverové verze
    • Důsledky: lokální uživatel může spouště kód se zvýšenými právy
    • Příčina: CoreServices démon může dovolit lokálnímu uživateli získat práva k odesílání dat na Mach task port, což může vést ke spuštění nežádoucího kódu. Aktualizace řeší problém přes vylepšenou kontrolu komunikace mezi procesy v CoreServices. Problém se vyskytuje až od Mac OS X 10.4.
  • diskdev_cmds
    • CVE-ID: CVE-2007-0734
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9, klientské i serverové verze
    • Důsledky: Otevřením diskového image s UFS filesystémem může způsobit neočekávané ukončení aplikace nebo spuštění nežádoucího kódu.
    • Příčina: Program fsck má chybu ve správě paměti a je možné způsobit aby fsck se spustilo automaticky na diskovou image, při jejím otevření. Vyzváním uživatele aby otevřel takto upravený disk nebo spustil fsck na upravený UFS filesystém může způsobit pád aplikace nebo spuštění nežádoucího kódu. Aktualizace řeší problém lepší kontrolou UFS souborového systému.
  • fetchmail
    • CVE-ID: CVE-2006-5867
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9, klientské i serverové verze
    • Důsledky: fetchmail odesílá heslo v nekódované podobě, přestože je nastaven aby používal TLS.
    • Příčina: fetchmail je aktualizován na verzi 6.3.6 aby se opravila chyba, která dovolovala odesílání hesla v nekódované podobě, nehledě na nastavení TLS. Problém je popsán na stránkách fetchmailu http://fetchmail.berlios.de/fetchmail-SA-2006-02.txt.
  • ftpd
    • CVE-ID: CVE-2006-6652
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9, klientské verze
    • Důsledky: FTP operace ověřeným FTP uživatelem může vést ke spuštění nežádoucího kódu
    • Příčina: lkemftpd byl aktualizován na verze tnftpd 20061217 aby se vyřešil problém s přetečením bufferu při zpracování příkazů, což mohlo vést ke spuštění nežádoucího kódu. Problém není u Mac OS X Serverů. Poděkování za nahlášení chyby patří Kevinovi Finisterrovi z Digital Munition za nahlášení chyby.
  • GNU Tar
    • CVE-ID: CVE-2006-0300
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Vylistováním nebo extrahování upravených tar archívů je možné spustit nežádoucí kód nebo ukončit aplikaci
    • Příčina: Při zpracování PAX rozšířených hlaviček v GNU tar archívu je chyba přetečení bufferu. Vyzváním uživatele aby si vylistovat nebo rozbalil upravených tar archív pak vede ke spuštění přetečení a potencionálně i ke spuštění nežádoucího kódu. Problém se vyřešil další kontrolou tar souborů. Problém nezahrnuje systém starší než Mac OS X 10.4.
  • Help Viewer
    • CVE-ID: CVE-2007-0646
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Otevření souboru s nápovědou, který má upravené jméno může vést k pádu aplikace nebo spuštění nežádoucího kódu
    • Příčina: Aplikace Help Viewer měla chybu při zpracování textových řetězců. Při vyzvání uživatele aby si stáhl a otevřel soubor s nápovědou, jež měl upravené jméno může vést k pádu aplikace nebo spustit nežádoucí kód. Problém byl popsán na stránkách Month of Apple Bugs (MOAB-30-01-2007). Aktualizace řeší problém eliminací jakýchkoliv zpracování textů se jmény souborů
  • HID Family
    • CVE-ID: CVE-2007-0724
    • Dostupný pro: Mac OS X 10.4 - 10.4.9 klientská i serverová verze
    • Důsledky: Události z konzolové klávesnice jsou k dispozici ostatním uživatelům na lokálním systému
    • Příčina: Nedostatečná kontrola v IOKit HID interface dovoluje aby jakýkoliv přihlášený uživatel mohl získat zmáčknuté klávesy, včetně hesel a dalších senzitivních informací. Tato aktualizace řeší problém omezení HID zařízení aby se data zpracovávala pouze procesy vlastněné současným konzolovým uživatelem. Poděkování za nahlášení chyby patří Andrew Garberovi z University of Victoria, Alexi Harperovi a Michalu Evansovi za nahlášení chyby. Tato oprava byla původně dodávaná u Mac OS X 10.4.9 aktualizace. Díky problému u přípravy instalačních balíčků se aktualizace nemusela dostat na váš počítač.
  • Installer
    • CVE-ID: CVE-2007-0465
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Otevřením instalačního balíčku s upraveným jménem může vést k ukončení aplikace a spuštění nežádoucího kódu
    • Příčina: V aplikaci Installer existuje problém se zpracováním jmen souborů. Vyzváním uživatele ke stažení a nainstalování instalačního balíčku s upraveným jménem může útočník způsobit pád aplikace nebo spuštění kódu. Problém byl popsán na Month of Apple Bugs stránkách (MOAB-26-01-2007). Aktualizace řeší problém odstraněním zpracovávání testových řetězců. Problém neexistuje na systémech starších než Mac OS X 10.4.
  • Kerberos
    • CVE-ID: CVE-2006-6143
    • Dostupný pro: 10.4.9 klientská i serverová verze
    • Důsledky: Spuštění administrativního démona Kerberos vede k neočekávanému ukončení nebo spuštění nežádoucího kódu
    • Příčina: Neinicializovaný ukazatel na funkci v MIT Kerberos administrační démonovi (kadmind), může vést k pádu aplikace a nebo spuštění nežádoucího kódu se systémovými právy. Další informace o problému a opravě jsou k dispozici na stránkách MIT Kerberos http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2006-002-rpc.txt.
  • Kerberos
    • CVE-ID: CVE-2007-0957
    • Dostupný pro: Mac OS X 10.3.9, 10.4.9 klientská i serverová verze
    • Důsledky: Spuštění administrativního démona Kerberos vede k neočekávanému ukončení nebo spuštění nežádoucího kódu
    • Příčina: Chyba přetečení bufferu v MIT Kerberos administrativním démonu (kadmind) stejně jako v KDC může vést k pádu aplikace nebo spuštění nežádoucího kódu. Další informace o problému a opravě jsou k dispozici na stránkách MIT Kerberos http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2007-002-syslog.txt.
  • Kerberos
    • CVE-ID: CVE-2007-1216
    • Dostupný pro: Mac OS X 10.3.9, 10.4.9 klientská i serverová verze
    • Důsledky: Spuštění administrativního démona Kerberos vede k neočekávanému ukončení nebo spuštění nežádoucího kódu
    • Příčina: Double free chyba (spuštění příkazu free na stejnou část paměti dvakrát po sobě) v GSS-API knihovně používaná Kerberos administrativním démonem (kadmind), což může vést k neočekávanému ukončení aplikace nebo spuštění nežádoucího kódu se systémovými právy. Další informace o problému a opravě jsou k dispozici na stránkách MIT Kerberos http://web.mit.edu/kerberos/advisories/MITKRB5-SA-2007-003.txt.
  • Libinfo
    • CVE-ID: CVE-2007-0735
    • Dostupný pro: Mac OS X 10.3.9, 10.4.9 klientská i serverová verze
    • Důsledky: Návštěva www stránek může vést k neočkávanému pádu aplikace nebo spuštění kódu
    • Příčina: V některých případech, Libinfo nesprávně ohlašuje chyby aplikaci, která ji používá. Vyzváním uživatele aby navštívil upravenou www stránk,může útoční způsobit aby se přistoupilo k již dealokovanému objektu a způsobit tak pád aplikace nebo spuštění nežádoucího kódu. Aktualizace opravuje problém provedením další kontrol v Libinfo. Poděkování patří Landonu Fullerovi z Three Rings Desing za nahlášení problému.
  • Libinfo
    • CVE-ID: CVE-2007-0736
    • Dostupný pro: Mac OS X 10.3.9, 10.4.9 klientská i serverová verze
    • Důsledky: Vzdálený útočník může způsobit přerušení služby nebo spuštění nežádoucího kódu, když je povolena služba portmap
    • Příčina: V RPC knihovně je chyba přetečení integeru. Odesláním upraveného požadavku na portmap službu může útočník způsobit přetečení, které vede k odmítnutí služby nebo spuštění kódu pod uživatelem "daemon". Aktualizace řeší problém další kontrolou požadavku. Poděkování za nahlášení chyby patří Mu Security Research Teamu.
  • Login Window
    • CVE-ID: CVE-2007-0737
    • Dostupný pro: Mac OS X 10.3.9, 10.4.9 klientská i serverová verze
    • Důsledky: Lokální úživatel může získat systémová práva
    • Příčina: Login Window nedostatečně kontroluje proměnné prostředí. To dovoluje lokálnímu uživateli spustit kód se systémovými právy. Aktualizace řeší problém lepší kontrolou proměnné prostředí u Login Window.
  • Login Window
    • CVE-ID: CVE-2007-0738
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Uživatel může obejít autentifikační dialog u Screen Saveru
    • Příčina: Za určitých podmínek jsou uživatelské předvolby vyžadující heslo po probuzení počítače ze spánku ignorovány a heslo není vyžadováno. Aktualizace řeší problém vylepšenou prací s touto předvolbou.
  • Login Window
    • CVE-ID: CVE-2007-0739
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Uživatel může obejít autentifikační dialogové okno
    • Příčina: Za určitých podmínek se okno programu Software Update dostane pod Login Window. To dovolí uživatel s fyzickým přístupem ke systému aby se přihlásil bez autorizace. Tento update řeší problém spuštění nastavených úloh po přihlášení uživatele. Problém se nevyskytuje na systémech starších Mac OS X 10.4.
  • network_cmds
    • CVE-ID: CVE-2007-0739
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Uživatel může obejít autentifikační dialogové okno
    • Příčina: Za určitých podmínek se okno programu Software Update dostane pod Login Window. To dovolí uživatel s fyzickým přístupem ke systému aby se přihlásil bez autorizace. Tento update řeší problém spuštění nastavených úloh po přihlášení uživatele. Problém se nevyskytuje na systémech starších Mac OS X 10.4.
  • network_cmds
    • CVE-ID: CVE-2007-0741
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Vzdálený útočník může způsobit přerušení služby nebo spuštění nežádoucího kódu při zapnutém Sdílení internetu.
    • Příčina: Při zpracovávání RTSP paketů v natd je chyba přetečení bufferu. Odesláním upravených RTSP paketů může vést k pádu aplikace nebo spuštění kódu. Problém zasahuje pouze uživatele, kteří mají nastaveno Sdílení Internetu. Aktualizace řeší problém lepší kontrolou RTSP paketů.
  • SMB
    • CVE-ID: CVE-2007-0744
    • Dostupný pro: Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Lokální uživatel může získat systémová práva.
    • Příčina: Za určitých okolností, SMB může spustit příkaz bez vyčištěného prostředí. To může dovolit lokálnímu uživateli aby vytvořil soubory nebo spustil příkaz se systémovými právy. Tato aktualizace řeší problém vyčištěním prostředí před spouštěním příkazů.
  • System Configuration
    • CVE-ID: CVE-2007-0022
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Lokální administrátoři mohou spustit kód se systémovými právy bez autorizace.
    • Příčina: Administrátoři mohou upravovat systémové předvolby mocoí writeconfig nástorje. Když writeconfig spouštění launchctl utilitu, nevyčistí prostředí zděděné po uživateli. To dovoluje spuštění kódu se systémovými právy bez autorizace. Problém byl popsán na stránkách Month of Apple BUgs (MOAB-21-01-2007). Aktulizace čistí prostředí před volání launchctl utility.
  • URLMount
    • CVE-ID: CVE-2007-0743
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Lokální uživatel může získat přihlašovací údaje jiného uživatele.
    • Příčina: Uživatelské jméno a heslo je použito pro připojení vzdálených souborových systémů přes připojení k SMB serverů přes mount_smb příkaz s argumenty, které je mohou prozradit dalším lokálním uživatelům. Tato aktualizace přístupové informace odesílá programu mount_smb již bezpečnou cestou. Poděkování patří Danielu Ballovi z Pittsburg Technical Institute, Geoffu Franksovi z Hauptman Woodward Medical Research Insitututu a Jamie Coxovi ze Sophos Pilc za nahlášení problému.
  • VideoConference
    • CVE-ID: CVE-2007-0746
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Vzdálený útočník může způsobit pdá aplikace nebo spuštění nežádoucího kódu při puštěném iChatu.
    • Příčina: Ve VideoConference frameworku je chyba heap buffer overflow. Odesláním upraveného SIP paketu při inicializace audio/video konference, útočník může spustit přeteční, které povede ke spuštění kódu. Aktualizace řeší problém další kontrolou SIP paketů.
  • WebDAV
    • CVE-ID: CVE-2007-0747
    • Dostupný pro: Mac OS X 10.3.9, Mac OS X 10.4.9 klientská i serverová verze
    • Důsledky: Lokální uživatel může získat systémová práva.
    • Příčina: Při připojení WebDAV souborového systému, load_webdav program může být spuštěn bez řádně vyčištěného prostředí. To může dovolituživateli vytvářet soubory nebo spouštět příkazy se systémovými právy. Aktulizace řeší problém vyčištěním prostředí před spouštěním příkazů.
  • WebFoundation
    • CVE-ID: CVE-2007-0742
    • Dostupný pro: Mac OS X 10.3.9 klientská i serverová verze
    • Důsledky: Cookies, které byly nastaveny v subdoméně byly přístupné i pro nadřazenou doménu.
    • Příčina: Implementační problém dovoluje cookies nastavit subdoménu přístupnou z nadřazené domény, což vede k odhalování senzitivních informací. Tato aktualizace opravuje problém další kontrolou domény ze které cookie pochází. Problém se neobjevuje na systémech s Mac OS X 10.4. Poděkování za nahlášení chyby patří Bradleymu Schwoererovi z University of Wisconsin-Madison.
Poslat Bezpečnostní balíček Apple 2007-004 na facebook
Publikováno 20.4.2007
 

Změna barev | Autorská práva | Kontakt | Podpora | RSS kanály
© 2006 Gandalf, Design by Mirek
Creative Commons License